e Bool Op Result
Class full path: NemAll_Python_Geometry.eBoolOpResult
Bases: IntEnum
bool operation result
Used for an identification of boolean operation's result
eInside : inside other geometry eOutside : outside other geometry eClip : partly inside other geometry
Attributes
eClip = 2
class-attribute
instance-attribute
eInside = 0
class-attribute
instance-attribute
eOutside = 1
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eBoolOpResult
|
value for the key |