e Box Point
Class full path: NemAll_Python_Geometry.eBoxPoint
Bases: IntEnum
Dedicated location of the box 4----8----3 | | 9 5 7 | | 1----6----2
Attributes
eCenter = 5
class-attribute
instance-attribute
eLeftBottom = 1
class-attribute
instance-attribute
eLeftTop = 4
class-attribute
instance-attribute
eMiddleBottom = 6
class-attribute
instance-attribute
eMiddleLeft = 9
class-attribute
instance-attribute
eMiddleRight = 7
class-attribute
instance-attribute
eMiddleTop = 8
class-attribute
instance-attribute
eRightBottom = 2
class-attribute
instance-attribute
eRightTop = 3
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eBoxPoint
|
value for the key |