e Clothoid Type
Class full path: NemAll_Python_Geometry.eClothoidType
Bases: IntEnum
Clothoid type identification
Attributes
eClothoid = 1
class-attribute
instance-attribute
eParabolaGeneral = 3
class-attribute
instance-attribute
eParabolaQuadratic = 2
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eClothoidType
|
value for the key |