e Fillet Type
Class full path: NemAll_Python_Geometry.eFilletType
Bases: IntEnum
Enumeration for the type of Fillet
Attributes
FT_CC_CONCETRIC = 33
class-attribute
instance-attribute
FT_CC_NO_INTERSECTION = 32
class-attribute
instance-attribute
FT_CC_ONE_INTERSECTION = 31
class-attribute
instance-attribute
FT_CC_TWO_INTERSECTION = 30
class-attribute
instance-attribute
FT_KK_KURVE_ELEMENTS = 40
class-attribute
instance-attribute
FT_KK_PARALLEL_KURVE_ELEMENTS = 41
class-attribute
instance-attribute
FT_LC_NO_INTERSECTION = 22
class-attribute
instance-attribute
FT_LC_ONE_INTERSECTION = 21
class-attribute
instance-attribute
FT_LC_TWO_INTERSECTION = 20
class-attribute
instance-attribute
FT_LL_INTERSECTION_AT_THE_END = 11
class-attribute
instance-attribute
FT_LL_INTERSECTION_ON_LINE = 10
class-attribute
instance-attribute
FT_LL_INTERSECTION_OUT_OF_LINES = 12
class-attribute
instance-attribute
FT_LL_PARALLEL_LINES = 13
class-attribute
instance-attribute
FT_UNKNOWN = 0
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eFilletType
|
value for the key |