e Planar Surface Error
Class full path: NemAll_Python_Geometry.ePlanarSurfaceError
Bases: IntEnum
Planar surface creation error
Attributes
eCollinear = 0
class-attribute
instance-attribute
eError = 3
class-attribute
instance-attribute
eNotContinuous = 2
class-attribute
instance-attribute
eNotPlanar = 1
class-attribute
instance-attribute
eOK = 4
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
ePlanarSurfaceError
|
value for the key |