e Polyhedron Healing Settings
Class full path: NemAll_Python_Geometry.ePolyhedronHealingSettings
Bases: IntEnum
Type of Healing settings for polyhedron
Used for identification of Healing settings type for polyhedron.
Attributes
HSET_NOMODIFY = 2
class-attribute
instance-attribute
HSET_TILT = 1
class-attribute
instance-attribute
HSET_TRIANGULATE = 0
class-attribute
instance-attribute
HSET_UNKNOWN = 3
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
ePolyhedronHealingSettings
|
value for the key |