e Projection Matrix Type
Class full path: NemAll_Python_Geometry.eProjectionMatrixType
Bases: IntEnum
Type of projection in Matrix3D
Used for an identification of what kind of projection is in Matrix3D.
Attributes
BOTTOM_2D = 5
class-attribute
instance-attribute
FREE_3D = 6
class-attribute
instance-attribute
FRONT_2D = 2
class-attribute
instance-attribute
LEFT_2D = 0
class-attribute
instance-attribute
REAR_2D = 3
class-attribute
instance-attribute
RIGHT_2D = 1
class-attribute
instance-attribute
TOP_2D = 4
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eProjectionMatrixType
|
value for the key |