Axis Element Adapter
Class full path: NemAll_Python_IFW_ElementAdapter.AxisElementAdapter
Bases: BaseElementAdapter
Implementation of the axis element adapter
Functions
GetAxis()
Get wall axis
Returns:
Type | Description |
---|---|
object
|
IGeometry2D arbitrary curve pointer |
GetGeometry()
copydoc BaseElementAdapter::GetGeometry
GetTiersCount()
Get the amount of tiers
Returns:
Type | Description |
---|---|
int
|
number of tiers of this axis element |
HasAxis()
Check, if this element has an axis
Returns:
Type | Description |
---|---|
bool
|
true, if axis element has an axis |
IsNull()
copydoc BaseElementAdapter::IsNull
__init__
overload
__init__()
Initialize
__init__(element)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
BaseElementAdapter
|
Element |
required |