Base Element Adapter Vector
Class full path: NemAll_Python_IFW_ElementAdapter.BaseElementAdapterVector
Functions
__getitem__(arg2)
Get a list item
Parameters:
Name | Type | Description | Default |
---|---|---|---|
index
|
Index of the item |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapter
|
Value for the index |
__iadd__(elements)
Add elements to the list
Parameters:
Name | Type | Description | Default |
---|---|---|---|
elements
|
BaseElementAdapterVector
|
Elements. |
required |
__init__()
Initialize
__iter__()
List iterator
Returns:
Type | Description |
---|---|
Iterator
|
List iterator |
__len__()
Get the list length
Returns:
Type | Description |
---|---|
int
|
Length of the list |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |
append(value)
Append a list item
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
BaseElementAdapter
|
Value to append |
required |