Document Name Service
Class full path: NemAll_Python_IFW_ElementAdapter.DocumentNameService
Functions
GetActiveDocumentName()
staticmethod
Get the name of the active document
Returns:
Type | Description |
---|---|
str
|
Name of the active document |
GetDocumentName(ele, withNumber, withLabel, delimiter)
staticmethod
Get the name of the element
Parameters:
Name | Type | Description | Default |
---|---|---|---|
ele
|
BaseElementAdapter
|
Element |
required |
withNumber
|
bool
|
Add the document number: true/false |
required |
withLabel
|
bool
|
Add the label: true/false |
required |
delimiter
|
str
|
Delimiter between number and name |
required |
Returns:
Type | Description |
---|---|
str
|
Name of the document |
GetDocumentNameByFileIndex(fileIndex, withNumber, withLabel, delimiter)
staticmethod
Get the document name by the document index (load index)
Parameters:
Name | Type | Description | Default |
---|---|---|---|
fileIndex
|
int
|
Document file index |
required |
withNumber
|
bool
|
Add the document number: true/false |
required |
withLabel
|
bool
|
Add the label: true/false |
required |
delimiter
|
str
|
Delimiter between number and name |
required |
Returns:
Type | Description |
---|---|
str
|
Document name |
GetDocumentNameByFileNumber(fileNumber, withNumber, withLabel, delimiter)
staticmethod
Get the document name by the file number
Parameters:
Name | Type | Description | Default |
---|---|---|---|
fileNumber
|
int
|
Document file number |
required |
withNumber
|
bool
|
Add the document number: true/false |
required |
withLabel
|
bool
|
Add the label: true/false |
required |
delimiter
|
str
|
Delimiter between number and name |
required |
Returns:
Type | Description |
---|---|
str
|
Document name |
GetLoadedDocumentsNameData()
staticmethod
Get the names and file numbers of the loaded documents
Returns:
Type | Description |
---|---|
list[tuple[str, int]]
|
Names of the loaded documents |