Building Element Input Controls
Class full path: NemAll_Python_IFW_Input.BuildingElementInputControls
Implementation of the building element input controls
Functions
CloseControls()
Close the input controls
CreateControls(handlePropList, insertionMat, viewProj, bUpdateControls, assoRefObj)
Create the controls
Parameters:
Name | Type | Description | Default |
---|---|---|---|
handlePropList
|
object
|
List with the handle properties |
required |
insertionMat
|
Matrix3D
|
Transformation matrix |
required |
viewProj
|
ViewWorldProjection
|
View world projection |
required |
bUpdateControls
|
bool
|
Update the controls: true/false |
required |
assoRefObj
|
object
|
Reference element for the drawing inside the associative views |
required |
__init__
overload
__init__()
Initialize
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
BuildingElementInputControls
|
Element to copy |
required |