Input Function Starter
Class full path: NemAll_Python_IFW_Input.InputFunctionStarter
Functions
RemoveFunction()
staticmethod
Remove the current input function from the input function stack
StartElementSelect(text, selectSetting, postSel, markSelectedElements, selectionMode=eSelectGeometry)
staticmethod
Start the element selection
A standard element selection will be started as overloaded function. The function will be removed if the selection is finished and elements are selected.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
text
|
str
|
Request string as resource ID, CAllstring, TCHAR or CString |
required |
selectSetting
|
ElementSelectFilterSetting
|
Filter setting |
required |
postSel
|
PostElementSelection
|
Post element selection |
required |
markSelectedElements
|
bool
|
Mark the selected elements: True/False |
required |
selectionMode
|
SelectionMode
|
Selection mode |
eSelectGeometry
|