Polygon Input
Class full path: NemAll_Python_IFW_Input.PolygonInput
Bases: CoordinateInput
, InputViewDocumentData
Implementation of the polygon input
Functions
ExecuteInput(mouseMsg, pnt, pMsgInfo)
Execute the input
Parameters:
Name | Type | Description | Default |
---|---|---|---|
mouseMsg
|
int
|
Mouse message |
required |
pnt
|
Point2D
|
View input point |
required |
pMsgInfo
|
AddMsgInfo
|
Additional message info |
required |
Returns:
Type | Description |
---|---|
int
|
execution state |
GetPolygon()
get the final polygon
Returns:
Type | Description |
---|---|
Polygon3D
|
final polygon |
GetPreviewPolygon()
get the preview polygon
Returns:
Type | Description |
---|---|
Polygon3D
|
preview polygon |
StartNewInput()
Start new input
__init__(coordInput, bZCoord, multiPolygon)
Args: coordInput: Coordinate input object bZCoord: Z-coordinate input state multiPolygon: Multi polygon with openings, ...