Select Elements Service
Class full path: NemAll_Python_IFW_Input.SelectElementsService
Classes
eSelectCondition
Bases: IntEnum
Element selection condition
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eSelectCondition
|
value for the key |
Functions
SelectByPolygon(polygon, viewProjection, selCond, filter)
staticmethod
Select an element by a point
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
Document |
required | |
polygon
|
Polygon2D
|
surrounding search polygon (view coordinates) |
required |
viewProjection
|
ViewWorldProjection
|
Identification of view projection (window) |
required |
selCond
|
eSelectCondition
|
True when elements inside rectangle must be selected only |
required |
filter
|
SelectionQuery
|
Selection filter |
required |
activationData
|
Activation data |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Data of the selected elements |
SelectByRect(cursorLeftBottomPoint, cursorRightTopPoint, viewProjection, selCond, filter)
staticmethod
Select an element by a point
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
Document |
required | |
cursorLeftBottomPoint
|
Point2D
|
Coordinate of left bottom point where elements will be searching |
required |
cursorRightTopPoint
|
Point2D
|
Coordinate of right top point where elements will be searching |
required |
viewProjection
|
ViewWorldProjection
|
Identification of view projection (window) |
required |
selCond
|
eSelectCondition
|
True when elements inside rectangle must be selected only |
required |
filter
|
SelectionQuery
|
Selection filter |
required |
activationData
|
Activation data |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Data of the selected elements |