Selection Query
Class full path: NemAll_Python_IFW_Input.SelectionQuery
Implementation of the selection query
Functions
Clear()
Clear the query
IsEmpty()
Check for an empty query
Returns:
Type | Description |
---|---|
bool
|
Filter is empty: true/false |
__init__
overload
__init__()
Initialize
__init__(query)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
query
|
SelectionQuery
|
Query to copy |
required |
__init__(query)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
query
|
Union[List[Union[QueryTypeID, object]], Union[QueryTypeID, object]]
|
Selection query as list with queries or single query. |
required |
The
|
queries can be a QueryTypeID or a class with a call member |
required |