e Split Element3D
Class full path: NemAll_Python_IFW_Input.eSplitElement3D
Bases: IntEnum
Split type for 3D elements
Attributes
ELEMENT3D_EDGES = 2
class-attribute
instance-attribute
ELEMENT3D_FACES = 1
class-attribute
instance-attribute
ELEMENT3D_NO_SPLIT = 0
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eSplitElement3D
|
value for the key |