Fixture Properties
Class full path: NemAll_Python_Palette.FixtureProperties
Attributes
Element: None
property
Property access for the element
:type: None
Group: None
property
Property access for the group
:type: None
Path: None
property
Property access for the path
:type: None
PathShortcut: None
property
Property access for the path shortcut
:type: None
Functions
GetElement()
Get the element
Returns:
Type | Description |
---|---|
str
|
Element |
GetGroup()
Get the group
Returns:
Type | Description |
---|---|
str
|
Group |
GetLastFixturePath()
staticmethod
Get the last fixture path
Returns:
Type | Description |
---|---|
str
|
Last fixture path |
GetPath()
Get the path
Returns:
Type | Description |
---|---|
str
|
Path |
OpenFixtureDialog(fixturePath)
staticmethod
Open the symbol library dialog
Returns:
Type | Description |
---|---|
str
|
result path |
Parameters:
Name | Type | Description | Default |
---|---|---|---|
fixturePath
|
str
|
Path to .sym file |
required |
__eq__(other)
Comparison of fixture properties.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
other
|
FixtureProperties
|
Compared fixture properties. |
required |
Returns:
Type | Description |
---|---|
object
|
True when fixture properties are equal, otherwise false. |
__init__
overload
__init__()
Initialize
__init__(pathShortcut, group, element)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
pathShortcut
|
str
|
Path shortcut (Office/Project/Privat) |
required |
group
|
str
|
Group name |
required |
element
|
str
|
Element name |
required |
__init__(FixtureProperties)
Copy Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
FixtureProperties
|
FixtureProperties
|
|
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |