Palette Value Type
Class full path: NemAll_Python_Palette.PaletteValueType
Bases: IntEnum
Types of the palette values
Attributes
ANGLE = 2
class-attribute
instance-attribute
DOUBLE = 6
class-attribute
instance-attribute
INTEGER = 5
class-attribute
instance-attribute
LENGTH = 1
class-attribute
instance-attribute
STRING = 3
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
PaletteValueType
|
value for the key |