Fixture Slide Type
Class full path: NemAll_Python_Precast.FixtureSlideType
Bases: IntEnum
fixture slide types
Attributes
eCode = 1
class-attribute
instance-attribute
eExtension = 5
class-attribute
instance-attribute
eGeometry = 0
class-attribute
instance-attribute
eReinforcement = 2
class-attribute
instance-attribute
eReport = 3
class-attribute
instance-attribute
eUndergroundCadaster = 4
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
FixtureSlideType
|
value for the key |