Precast Layer Properties
Class full path: NemAll_Python_Precast.PrecastLayerProperties
PrecastLayerProperties class
Attributes
CalculateLayerThickness: None
property
Property for CalculateLayerThickness
:type: None
LayerName: None
property
Property for LayerName
:type: None
LayerNumber: None
property
Property for LayerNumber
:type: None
LayerThickness: None
property
Property for LayerThickness
:type: None
Material: None
property
Property for Material
:type: None
MaterialCatAddressOffset: None
property
Property for MaterialCatAddressOffset
:type: None
MaterialType: None
property
Property for MaterialType
:type: None
Functions
SetMaterialCatalogAddressOffset(arg2, arg3)
Set the materialCatAddressOffset
Returns:
Type | Description |
---|---|
int
|
materialCatAddressOffset |
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
PrecastLayerProperties
|
PrecastLayerProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
Initialize
__repr__()
Convert to string