Bar Placement
Class full path: NemAll_Python_Reinforcement.BarPlacement
Bases: ReinfElement
, AllplanElement
Implementation of the bar placement element
Attributes
BendingShape: BendingShape
property
writable
Get the shape polyline
BendingShapeMatrix: NemAll_Python_Geometry.Matrix3D
property
writable
Get the bending shape matrix
CommonProperties: NemAll_Python_BaseElements.CommonProperties
property
writable
Get the common properties
DistanceVector: NemAll_Python_Geometry.Vector3D
property
writable
Get the distance vector
EndBendingShape: BendingShape
property
writable
Get the shape polyline at the end of a polygonal placement
LengthFactor: float
property
writable
Get the length factor
PlacePerLinearMeter: bool
property
writable
Get the place per linear meter state
PositionNumber: int
property
writable
Get the position number
RotationAxis: NemAll_Python_Geometry.Line3D
property
writable
Get the rotation axis
Functions
GetBarCount()
Get the bar count
Returns:
Type | Description |
---|---|
int
|
Bar count |
GetBendingShape()
Get the shape polyline
Returns:
Type | Description |
---|---|
BendingShape
|
Shape polyline |
GetBendingShapeMatrix()
Get the bending shape matrix
Returns:
Type | Description |
---|---|
Matrix3D
|
Bending shape matrix |
GetCommonProperties()
Get the common properties
Returns:
Type | Description |
---|---|
CommonProperties
|
Common properties |
GetDistanceVector()
Get the distance vector
Returns:
Type | Description |
---|---|
Vector3D
|
Distance vector |
GetEndBendingShape()
Get the shape polyline at the end of a polygonal placement
Returns:
Type | Description |
---|---|
BendingShape
|
Shape polyline |
GetEndPoint()
Get the end point of the placement at the placement line
Returns:
Type | Description |
---|---|
Point3D
|
End point of the placement at the placement line |
GetLabel()
Get the label
Returns:
Type | Description |
---|---|
ReinforcementLabel
|
Label |
GetLengthFactor()
Get the length factor
Returns:
Type | Description |
---|---|
float
|
Length factor |
GetPositionNumber()
Get the position number
Returns:
Type | Description |
---|---|
int
|
Position number |
GetRotationAngle()
Get the rotation angle
Returns:
Type | Description |
---|---|
Angle
|
Rotation angle |
GetRotationAxis()
Get the rotation axis
Returns:
Type | Description |
---|---|
Line3D
|
Rotation axis |
GetStartPoint()
Get start point of the placement at the placement line
Returns:
Type | Description |
---|---|
Point3D
|
Start point of the placement at the placement line |
IsPlacePerLinearMeter()
Get the place per linear meter state
Returns:
Type | Description |
---|---|
bool
|
Place per linear meter: true/false |
IsPolygonalPlacement()
Get the polygonal placement state
Returns:
Type | Description |
---|---|
bool
|
Polygonal placement: true/false |
IsRotationalPlacement()
Get the rotational placement state
Returns:
Type | Description |
---|---|
bool
|
Rotational placement: true/false |
Move(transVec)
Move the placement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
transVec
|
Vector3D
|
Move vector |
required |
SetBendingShape(shape)
Set the reinforcement shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
shape
|
BendingShape
|
Reinforcement shape |
required |
SetBendingShapeMatrix(bendingShapeMat)
Set the bending shape matrix
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bendingShapeMat
|
Matrix3D
|
Bending shape matrix |
required |
SetCommonProperties(commonProp)
Set the common properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
SetDistanceVector(distVec)
Set the distance vector
Parameters:
Name | Type | Description | Default |
---|---|---|---|
distVec
|
Vector3D
|
Distance vector |
required |
SetEndBendingShape(shape)
Set the reinforcement shape at the end
Parameters:
Name | Type | Description | Default |
---|---|---|---|
shape
|
BendingShape
|
Reinforcement shape |
required |
SetLabel(label, labelAssocView)
Set the label
Parameters:
Name | Type | Description | Default |
---|---|---|---|
label
|
ReinforcementLabel
|
Label |
required |
labelAssocView
|
AssocViewElementAdapter
|
Associative view for the label |
required |
SetLengthFactor(lengthFactor)
Set the length factor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
lengthFactor
|
float
|
Length factor |
required |
SetPlacePerLinearMeter(bPlacePerLinearMeter)
Set the place per linear meter state
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bPlacePerLinearMeter
|
bool
|
Place per linear meter: true/false |
required |
SetPositionNumber(positionNumber)
Set the position number
Parameters:
Name | Type | Description | Default |
---|---|---|---|
positionNumber
|
int
|
Position number |
required |
SetRotationAxis(rotationAxis)
Set the rotation axis
Parameters:
Name | Type | Description | Default |
---|---|---|---|
rotationAxis
|
Line3D
|
Rotation axis |
required |
Transform(transMat)
Transform the placement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
transMat
|
Matrix3D
|
Transformation matrix |
required |
__init__
overload
__init__()
Initialize
__init__(placement)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placement
|
BarPlacement
|
Placement to copy |
required |
__init__(positionNumber, barCount, distVec, startPnt, endPnt, bendingShape)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
positionNumber
|
int
|
Position number |
required |
barCount
|
int
|
Bar count |
required |
distVec
|
Vector3D
|
Distance vector |
required |
startPnt
|
Point3D
|
Start point of the placement at the placement line |
required |
endPnt
|
Point3D
|
End point of the placement at the placement line |
required |
bendingShape
|
BendingShape
|
Bending shape |
required |
__init__(positionNumber, barCount, startBendingShape, endBendingShape)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
positionNumber
|
int
|
Position number |
required |
barCount
|
int
|
Bar count |
required |
startBendingShape
|
BendingShape
|
Start shape of the polygonal placement |
required |
endBendingShape
|
BendingShape
|
End shape of the polygonal placement |
required |
__init__(positionNumber, barCount, rotationAxis, rotationAngle, bendingShape)
Constructor for the rotational placement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
positionNumber
|
int
|
Position number |
required |
barCount
|
int
|
Bar count |
required |
rotationAxis
|
Line3D
|
Rotation point |
required |
rotationAngle
|
Angle
|
Rotation angle |
required |
bendingShape
|
BendingShape
|
Bending shape |
required |
__repr__()
Convert to string