Bar Position Data
Class full path: NemAll_Python_Reinforcement.BarPositionData
Implementation of the bar position data
Attributes
Count: int
property
writable
Get the count
Diameter: float
property
writable
Get the diameter
Length: float
property
writable
Get the length
Position: int
property
writable
Get the position number
SteelGrade: int
property
writable
Get the steel grade
Functions
GetCount()
Get the count
Returns:
Type | Description |
---|---|
int
|
Count |
GetDiameter()
Get the diameter
Returns:
Type | Description |
---|---|
float
|
diameter |
GetLength()
Get the length
Returns:
Type | Description |
---|---|
float
|
length |
GetPosition()
Get the position number
Returns:
Type | Description |
---|---|
int
|
Position number |
GetSteelGrade()
Get the steel grade
Returns:
Type | Description |
---|---|
int
|
Steel grade |
SetCount(count)
Set the count
Parameters:
Name | Type | Description | Default |
---|---|---|---|
count
|
int
|
Count |
required |
SetDiameter(diameter)
Set the diameter
Parameters:
Name | Type | Description | Default |
---|---|---|---|
diameter
|
float
|
diameter |
required |
SetLength(length)
Set the length
Parameters:
Name | Type | Description | Default |
---|---|---|---|
length
|
float
|
length |
required |
SetPosition(position)
Set the position number
Parameters:
Name | Type | Description | Default |
---|---|---|---|
position
|
int
|
Position |
required |
SetSteelGrade(steelGrade)
Set the steel grade
Parameters:
Name | Type | Description | Default |
---|---|---|---|
steelGrade
|
int
|
steel grade |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
BarPositionData
|
Element to copy |
required |
__repr__()
Convert to string