Circular Area Element
Class full path: NemAll_Python_Reinforcement.CircularAreaElement
Bases: ReinfElement
, AllplanElement
Implementation of the bar placement element
Attributes
LengthFactor: float
property
writable
Get the length factor
PlacePerLinearMeter: bool
property
writable
Get the place per linear meter state
Functions
GetConcreteCoverContour()
Get the concrete cover from the contour
Returns:
Type | Description |
---|---|
float
|
Concrete cover from the contour |
GetConcreteCoverEnd()
Get the concrete cover from the end
Returns:
Type | Description |
---|---|
float
|
Concrete cover from the end |
GetConcreteCoverStart()
Get the concrete cover from the start
Returns:
Type | Description |
---|---|
float
|
Concrete cover from the start |
GetConcreteGrade()
Get the concrete grade
Returns:
Type | Description |
---|---|
int
|
Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings) |
GetContourPoints()
Get the contour points
Returns:
Type | Description |
---|---|
Polyline3D
|
Contour points |
GetDiameter()
Get the diameter
Returns:
Type | Description |
---|---|
float
|
Diameter |
GetDistance()
Get the distance
Returns:
Type | Description |
---|---|
float
|
Distance |
GetEvenFirstLength()
Get the first length for the even ring number
Returns:
Type | Description |
---|---|
float
|
First length for the even ring number |
GetEvenOverlapEnd()
Get the overlap length at the end for the even ring number
Returns:
Type | Description |
---|---|
float
|
Overlap length at the end for the even ring number |
GetEvenOverlapStart()
Get the overlap length at the start for the even ring number
Returns:
Type | Description |
---|---|
float
|
Overlap length at the start for the even ring number |
GetLengthFactor()
Get the length factor
Returns:
Type | Description |
---|---|
float
|
Length factor |
GetMaxBarLength()
Get the maximal bar length
Returns:
Type | Description |
---|---|
float
|
Maximal bar length |
GetMaxBarRise()
Get the maximal bar radius
Returns:
Type | Description |
---|---|
float
|
Maximal bar radius |
GetMinBarLength()
Get the minimal bar length
Returns:
Type | Description |
---|---|
float
|
Minimal bar length |
GetMinBarRadius()
Get the minimal bar radius
Returns:
Type | Description |
---|---|
float
|
Minimal bar radius |
GetOddFirstLength()
Get the first length for the odd ring number
Returns:
Type | Description |
---|---|
float
|
First length for the odd ring number |
GetOddOverlapEnd()
Get the overlap length at the end for the odd ring number
Returns:
Type | Description |
---|---|
float
|
Overlap length at the end for the odd ring number |
GetOddOverlapStart()
Get the overlap length at the start for the even ring number
Returns:
Type | Description |
---|---|
float
|
Overlap length at the start for the odd ring number |
GetOuterAngleEnd()
Get the outer angle at the end
Returns:
Type | Description |
---|---|
float
|
Outer angle at the end |
GetOuterAngleStart()
Get the outer angle at the start
Returns:
Type | Description |
---|---|
float
|
Outer angle at the start |
GetOverlapLength()
Get the overlap length
Returns:
Type | Description |
---|---|
float
|
Overlap length |
GetPlacementRule()
Get the placement rule
Returns:
Type | Description |
---|---|
int
|
Placement rule |
GetPositionNumber()
Get the position number
Returns:
Type | Description |
---|---|
int
|
Position number |
GetRotationAxis()
Get the rotation axis
Returns:
Type | Description |
---|---|
Line3D
|
Rotation axis |
GetSteelGrade()
Get the steel grade
Returns:
Type | Description |
---|---|
int
|
Steel grade |
GetinnerAngleEnd()
Get the inner angle at the end
Returns:
Type | Description |
---|---|
float
|
Inner angle at the end |
GetinnerAngleStart()
Get the inner angle at the start
Returns:
Type | Description |
---|---|
float
|
Inner angle at the start |
IsPlacePerLinearMeter()
Get the place per linear meter state
Returns:
Type | Description |
---|---|
bool
|
Place per linear meter: true/false |
IsbOverlapEndAsCircle()
Get the overlap state at the end
Returns:
Type | Description |
---|---|
bool
|
Overlap length at the end as circle = true, as tangent = false |
IsbOverlapStartAsCircle()
Get the overlap state at the start
Returns:
Type | Description |
---|---|
bool
|
Overlap length at the start as circle = true, as tangent = false |
SetBarProperties(distance, maxBarLength, minBarLength, placementRule, oddFirstLength, evenFirstLength, minBarRadius, maxBarRise)
Set the bar properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
distance
|
float
|
Distance |
required |
maxBarLength
|
float
|
Maximal bar length |
required |
minBarLength
|
float
|
Minimal bar length |
required |
placementRule
|
int
|
Placement rule |
required |
oddFirstLength
|
float
|
First length for the odd ring number |
required |
evenFirstLength
|
float
|
First bar length for the event ring number |
required |
minBarRadius
|
float
|
Minimal bar radius |
required |
maxBarRise
|
float
|
Maximal bar rise |
required |
SetLengthFactor(lengthFactor)
Set the length factor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
lengthFactor
|
float
|
Length factor |
required |
SetOverlap(oddOverlapStart, evenOverlapStart, bOverlapStartAsCircle, oddOverlapEnd, evenOverlapEnd, bOverlapEndAsCircle, overlapLength)
Set the overlap
Parameters:
Name | Type | Description | Default |
---|---|---|---|
oddOverlapStart
|
float
|
Overlap length at the start for the odd ring number |
required |
evenOverlapStart
|
float
|
Overlap length at the start for the even ring number |
required |
bOverlapStartAsCircle
|
bool
|
Overlap length at the start as circle = true, as tangent = false |
required |
oddOverlapEnd
|
float
|
Overlap length at the end for the odd ring number |
required |
evenOverlapEnd
|
float
|
Overlap length at the end for the even ring number |
required |
bOverlapEndAsCircle
|
bool
|
Overlap length at the end as circle = true, as tangent = false |
required |
overlapLength
|
float
|
Overlap length |
required |
SetPlacePerLinearMeter(bPlacePerLinearMeter)
Set the place per linear meter state
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bPlacePerLinearMeter
|
bool
|
Place per linear meter: true/false |
required |
__init__
overload
__init__()
Initialize
__init__(positionNumber, diameter, steelGrade, concreteGrade, rotationAxis, contourPoints, outerAngleStart, outerAngleEnd, innerAngleStart, innerAngleEnd, concreteCoverStart, concreteCoverEnd, concreteCoverContour)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
positionNumber
|
int
|
Position number |
required |
diameter
|
float
|
Diameter |
required |
steelGrade
|
int
|
Steel grade |
required |
concreteGrade
|
int
|
Concrete grade |
required |
rotationAxis
|
Line3D
|
Rotation axis |
required |
contourPoints
|
Polyline3D
|
Contour points |
required |
outerAngleStart
|
float
|
Outer angle at the start |
required |
outerAngleEnd
|
float
|
Outer angle at the end |
required |
innerAngleStart
|
float
|
Inner angle at the start |
required |
innerAngleEnd
|
float
|
Inner angle at the end |
required |
concreteCoverStart
|
float
|
Concrete cover at the start |
required |
concreteCoverEnd
|
float
|
Concrete cover at the end |
required |
concreteCoverContour
|
float
|
Concrete cover of the contour |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
CircularAreaElement
|
Element to copy |
required |
__repr__()
Convert to string