Divide Bars Parameters
Class full path: NemAll_Python_Reinforcement.DivideBarsParameters
Parameters for dividing engineering geometry
Attributes
DivideMode: DivideBarsParameters.eDivideMode
property
writable
Get the mode of division
GapLength: float
property
writable
Get the gap length
GapPosition: DivideBarsParameters.eLengthPosition
property
writable
Get the position of gap
OverlapLength: float
property
writable
Get the overlap length
OverlapPosition: DivideBarsParameters.eLengthPosition
property
writable
Get the position of overlap
Classes
eDivideMode
Bases: IntEnum
Information of Divide Mode
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eDivideMode
|
value for the key |
eInputMode
Bases: IntEnum
Information of input mode
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eInputMode
|
value for the key |
eLengthPosition
Bases: IntEnum
Information of position of Overlap-/Gap-Length
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eLengthPosition
|
value for the key |
Functions
GetTrimLens()
Get necessary length to lengthen/shorten bar parts
Returns:
Type | Description |
---|---|
float
|
tuple(lengthen/shorten left bar part, |
float
|
lengthen/shorten right bar part) |
__init__
overload
__init__()
Initialize
__init__(DivideMode, OverlapPosition, OverlapLength, GapPosition, GapLength)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
DivideMode
|
eDivideMode
|
Mode of division |
required |
OverlapPosition
|
eLengthPosition
|
Position of Overlap |
required |
OverlapLength
|
float
|
Overlap length |
required |
GapPosition
|
eLengthPosition
|
Position of Gap |
required |
GapLength
|
float
|
Gap length |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
DivideBarsParameters
|
Element to copy |
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |