Extrude Bar Placement
Class full path: NemAll_Python_Reinforcement.ExtrudeBarPlacement
Bases: ReinfElement
, AllplanElement
Implementation of the extrude bar placement element
Attributes
CommonProperties: NemAll_Python_BaseElements.CommonProperties
property
writable
Get the common properties
PositionNumber: int
property
writable
Get the position number
Classes
eEdgeOffsetType
Bases: IntEnum
Edge offset type
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eEdgeOffsetType
|
value for the key |
eProfileRotation
Bases: IntEnum
Profile rotation
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eProfileRotation
|
value for the key |
Functions
AddCrossBendingShape(shape)
Add a cross bending shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
shape
|
BendingShape
|
Reinforcement shape |
required |
AddLongitudinalBarProp(longitudinalBarProp)
Add the longitudinal bar properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
longitudinalBarProp
|
LongitudinalBarProperties
|
longitudinal bar properties |
required |
AddPlacementSection(placementSection)
Add a placement section
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placementSection
|
BarPlacementSection
|
Section |
required |
Returns:
Type | Description |
---|---|
bool
|
Section is added: true/false |
Extrude()
Extrude the bars
GetBarOffset()
Get the bar offset
Returns:
Type | Description |
---|---|
float
|
Bar offset |
GetBendingShapeViewVector()
Get the view vector of the bending shape
Returns:
Type | Description |
---|---|
Vector3D
|
View vector of the bending shape |
GetCommonProperties()
Get the common properties
Returns:
Type | Description |
---|---|
CommonProperties
|
Common properties |
GetConcreteCoverEnd()
Get the concrete cover at the end of the path
Returns:
Type | Description |
---|---|
float
|
Concrete cover at the end of the path |
GetConcreteCoverStart()
Get the concrete cover at the start of the path
Returns:
Type | Description |
---|---|
float
|
Concrete cover at the start of the path |
GetCrossBarDistance()
Get the cross bar distance
Returns:
Type | Description |
---|---|
float
|
Cross bar distance |
GetCrossBendingShapes()
Get the cross bending shapes
Returns:
Type | Description |
---|---|
BendingShapeList
|
Cross bending shapes |
GetEdgeOffsetEnd()
Get the edge offset at the end of the path
Returns:
Type | Description |
---|---|
float
|
Edge offset at the end of the path |
GetEdgeOffsetStart()
Get the edge offset at the start of the path
Returns:
Type | Description |
---|---|
float
|
Edge offset at the start of the path |
GetEdgeOffsetType()
Get the edge offset type
GetEdgeOffsets()
Get the edge offsets
Returns:
Type | Description |
---|---|
tuple
|
Edge offsets |
GetMaxBreakAngle()
Get the maximal break angle
Returns:
Type | Description |
---|---|
float
|
Maximal break angle |
GetPlacementPath()
Get the placement path
Returns:
Type | Description |
---|---|
Path3D
|
Placement path |
GetPlacementSections()
Get the placement sections
Returns:
Type | Description |
---|---|
object
|
Placement sections |
GetPositionNumber()
Get the position number
Returns:
Type | Description |
---|---|
int
|
Position number |
GetProfileRoation()
Get the profile rotation
Returns:
Type | Description |
---|---|
eProfileRotation
|
Profile rotation |
IsBreakElimination()
Get the break eliminination state
Returns:
Type | Description |
---|---|
bool
|
Break elimination state |
Move(transVec)
Move the placement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
transVec
|
Vector3D
|
Move vector |
required |
SetCommonProperties(commonProp)
Set the common properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
Transform(transMat)
Transform the placement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
transMat
|
Matrix3D
|
Transformation matrix |
required |
__init__
overload
__init__()
Initialize
__init__(placement)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placement
|
ExtrudeBarPlacement
|
Placement to copy |
required |
__init__(positionNumber, path, profileRotation, breakElimination, maxBreakAngle, crossBarDistance, concreteCoverStart, concreteCoverEnd, edgeOffsetType, edgeOffsetStart, edgeOffsetEnd, barOffset, bendingShapeViewVector)
Constructor for cross bars
Parameters:
Name | Type | Description | Default |
---|---|---|---|
positionNumber
|
int
|
Position number |
required |
path
|
Path3D
|
Path |
required |
profileRotation
|
eProfileRotation
|
Profile rotation |
required |
breakElimination
|
bool
|
Break elemination |
required |
maxBreakAngle
|
float
|
Maximal break angle |
required |
crossBarDistance
|
float
|
Cross bar distance |
required |
concreteCoverStart
|
float
|
Concrete cover at the start of the path |
required |
concreteCoverEnd
|
float
|
Concrete cover at the end of the path |
required |
edgeOffsetType
|
eEdgeOffsetType
|
Get the edge offset type of the path |
required |
edgeOffsetStart
|
float
|
Edge offset at the start of the path |
required |
edgeOffsetEnd
|
float
|
Edge offset at the end of the path |
required |
barOffset
|
float
|
Bar offset |
required |
bendingShapeViewVector
|
Vector3D
|
View vector of the bending shape |
required |
__repr__()
Convert to string