Geometry Expansion Util
Class full path: NemAll_Python_Reinforcement.GeometryExpansionUtil
Functions
GetLineAbove(arg2, arg3, arg4, arg5)
Get the line above the base line and the placement point
GetLineAtPoint(arg2, arg3, arg4, arg5)
Get the line at the defined point of the reference line
GetLineFromPoint(arg2, arg3, arg4, arg5)
Get the line near to the input point
GetLineLeft(arg2, arg3, arg4, arg5)
Get the line left from the base line and the placement point
__init__
overload
__init__()
Initialize
__init__(pMsgInfo, use3DGeometry)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
pMsgInfo
|
AddMsgInfo
|
Additional message info |
required |
use3DGeometry
|
bool
|
Use the 3D geometry for the expansione: true/false |
required |