Reinforcement Util
Class full path: NemAll_Python_Reinforcement.ReinforcementUtil
Functions
GetNextBarPositionNumber(doc)
staticmethod
Get the the next bar position number
Returns:
Type | Description |
---|---|
int
|
Next bar position number |
Args: doc: Document
GetNextMeshPositionNumber(doc)
staticmethod
Get the the next mesh position number
Returns:
Type | Description |
---|---|
int
|
Next mesh position number |
Args: doc: Document
Rearrange(doc, fromBarPosition=1, fromMeshPosition=1, toBarPosition=99999, toMeshPosition=99999, afterBarPosition=1, aftgerMeshPosition=1, tolerance=1.0, rearrangedLock=False, identicalShapes=False, identicalPrefix=False, createUndoStep=True)
staticmethod
Rearrange the reinforcement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
fromBarPosition
|
int
|
Rearrange from bar position |
1
|
fromMeshPosition
|
int
|
Rearrange from mesh position |
1
|
toBarPosition
|
int
|
Rearrange to bar position |
99999
|
toMeshPosition
|
int
|
Rearrange to mesh position |
99999
|
afterBarPosition
|
int
|
Rearrange after bar position |
1
|
afterMeshPosition
|
Rearrange after mesh position |
required | |
tolerance
|
float
|
Tolerance |
1.0
|
rearrangedLock
|
bool
|
Rearranged positions are locked state |
False
|
identicalShapes
|
bool
|
Rearrange identical shapes state |
False
|
identicalPrefix
|
bool
|
Rearrange identical prefix state |
False
|
createUndoStep
|
bool
|
Create the undo step state |
True
|
__init__()
Initialize