Sweep Bar Placement
Class full path: NemAll_Python_Reinforcement.SweepBarPlacement
Bases: ReinfElement
, AllplanElement
Implementation of the sweep bar placement element
Attributes
CommonProperties: NemAll_Python_BaseElements.CommonProperties
property
writable
Get the common properties
PositionNumber: int
property
writable
Get the position number
Classes
eEdgeOffsetType
Bases: IntEnum
Edge offset types
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eEdgeOffsetType
|
value for the key |
Functions
AddPlacementSection(placementSection)
Add a placement section
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placementSection
|
BarPlacementSection
|
Section |
required |
Returns:
Type | Description |
---|---|
bool
|
Section is added: true/false |
AddSectionBars(bendingShapes, sectionsLongitudinalBarsProp, sectionPlane)
Add the bars and the section plane for a section
bendingShapeViewVector View vector of the bending shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bendingShapes
|
BendingShapeList
|
Bending shapes of the section |
required |
sectionsLongitudinalBarsProp
|
LongitudinalBarPropertiesList
|
Longitudinal bars properties |
required |
sectionPlane
|
Plane3D
|
Section plane |
required |
GetBarOffset()
Get the bar offset
Returns:
Type | Description |
---|---|
float
|
Bar offset |
GetBenchingAngle()
Get the benching angle
Returns:
Type | Description |
---|---|
float
|
Benching angle |
GetBenchingLength()
Get the benching length
Returns:
Type | Description |
---|---|
float
|
Benching length |
GetCommonProperties()
Get the common properties
Returns:
Type | Description |
---|---|
CommonProperties
|
Common properties |
GetConcreteCoverEnd()
Get the concrete cover at the end of the path
Returns:
Type | Description |
---|---|
float
|
Concrete cover at the end of the path |
GetConcreteCoverStart()
Get the concrete cover at the start of the path
Returns:
Type | Description |
---|---|
float
|
Concrete cover at the start of the path |
GetCrossBarDistance()
Get the cross bar distance
Returns:
Type | Description |
---|---|
float
|
Cross bar distance |
GetEdgeOffsetEnd()
Get the edge offset at the end of the path
Returns:
Type | Description |
---|---|
float
|
Edge offset at the end of the path |
GetEdgeOffsetStart()
Get the edge offset at the start of the path
Returns:
Type | Description |
---|---|
float
|
Edge offset at the start of the path |
GetEdgeOffsetType()
Get the edge offset type
GetEdgeOffsets()
Get the edge offsets
Returns:
Type | Description |
---|---|
tuple
|
Edge offsets |
GetPlacementSections()
Get the placement sections
Returns:
Type | Description |
---|---|
object
|
Placement sections |
GetPositionNumber()
Get the position number
Returns:
Type | Description |
---|---|
int
|
Position number |
IsFirstPathIsSweepPath()
Get the first path is sweep path state
Returns:
Type | Description |
---|---|
bool
|
First path is sweep path state |
IsInterpolation()
Get the interpolation state
Returns:
Type | Description |
---|---|
bool
|
Interpolation state |
IsInterpolationOfAllPoints()
Get the interpolation of all points state
Returns:
Type | Description |
---|---|
bool
|
Interpolation of all points state |
IsRoation()
Get the rotation state
Returns:
Type | Description |
---|---|
bool
|
Rotation state |
Move(transVec)
Move the placement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
transVec
|
Vector3D
|
Move vector |
required |
SetCommonProperties(commonProp)
Set the common properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
SetPositionNumber(positionNumber)
Set the position number
Parameters:
Name | Type | Description | Default |
---|---|---|---|
positionNumber
|
int
|
Position number |
required |
Sweep()
Sweep the bars
Transform(transMat)
Transform the placement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
transMat
|
Matrix3D
|
Transformation matrix |
required |
__init__
overload
__init__()
Initialize
__init__(placement)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placement
|
SweepBarPlacement
|
Placement to copy |
required |
__init__(positionNumber, sweepPaths, rotation, firstPathIsSweepPath, interpolation, interpolationOfAllPoints, crossBarDistance, concreteCoverStart, concreteCoverEnd, edgeOffsetType, edgeOffsetStart, edgeOffsetEnd, barOffset, benchingLength, benchingAngle)
Constructor for cross bars
Parameters:
Name | Type | Description | Default |
---|---|---|---|
positionNumber
|
int
|
Position number |
required |
sweepPaths
|
Path3DList
|
Path |
required |
rotation
|
bool
|
Rotation |
required |
firstPathIsSweepPath
|
bool
|
First path is also sweep path |
required |
interpolation
|
bool
|
Interpolation |
required |
interpolationOfAllPoints
|
bool
|
Interpolation of all points |
required |
crossBarDistance
|
float
|
Cross bar distance |
required |
concreteCoverStart
|
float
|
Concrete cover at the start of the path |
required |
concreteCoverEnd
|
float
|
Concrete cover at the end of the path |
required |
edgeOffsetType
|
eEdgeOffsetType
|
Get the edge offset type of the path |
required |
edgeOffsetStart
|
float
|
Edge offset at the start of the path |
required |
edgeOffsetEnd
|
float
|
Edge offset at the end of the path |
required |
barOffset
|
float
|
Bar offset |
required |
benchingLength
|
float
|
Benching length |
required |
benchingAngle
|
float
|
Benching angle |
required |
__repr__()
Convert to string