File Dialog
Class full path: NemAll_Python_Utility.FileDialog
File dialog
Functions
AskOpenFavoriteFile(defaultPath, title, filters, extension)
staticmethod
Ask for a favorite file to open
Parameters:
Name | Type | Description | Default |
---|---|---|---|
defaultPath
|
str
|
Initial default path |
required |
title
|
str
|
Title of the dialog. If the title is empty an internal string will be used |
required |
filters
|
str
|
Filters of the files |
required |
extension
|
str
|
Extension of the file |
required |
Returns: selected file
AskOpenFile(defaultPath, title, filters, extension, defaultDir)
staticmethod
Ask for a file to open
Parameters:
Name | Type | Description | Default |
---|---|---|---|
defaultPath
|
str
|
Initial default path |
required |
title
|
str
|
Title of the dialog. If the title is empty an internal string will be used |
required |
filters
|
str
|
Filters of the files |
required |
extension
|
str
|
Extension of the file |
required |
defaultDir
|
DefaultDirectories
|
Default directories |
required |
Returns:
Type | Description |
---|---|
str
|
selected file |
AskSaveFavoriteFile(defaultPath, title, filters, extension)
staticmethod
Ask for a favorite file to save
Parameters:
Name | Type | Description | Default |
---|---|---|---|
defaultPath
|
str
|
Initial default path |
required |
title
|
str
|
Title of the dialog. If the title is empty an internal string will be used |
required |
filters
|
str
|
Filters of the files |
required |
extension
|
str
|
Extension of the file |
required |
Returns: selected file
AskSaveFile(defaultPath, title, filters, extension, defaultDir)
staticmethod
Ask for a file to save
Parameters:
Name | Type | Description | Default |
---|---|---|---|
defaultPath
|
str
|
Initial default path |
required |
title
|
str
|
Title of the dialog. If the title is empty an internal string will be used |
required |
filters
|
str
|
Filters of the files |
required |
extension
|
str
|
Extension of the file |
required |
defaultDir
|
DefaultDirectories
|
Default directories |
required |
Returns:
Type | Description |
---|---|
str
|
selected file |
__init__()
Initialize