GUID
Class full path: NemAll_Python_Utility.GUID
Functions
FromString(strGuid)
staticmethod
Create a GUID from a string
Parameters:
Name | Type | Description | Default |
---|---|---|---|
strGuid
|
str
|
GUID as string |
required |
Returns:
Type | Description |
---|---|
GUID
|
GUID from the string |
__eq__(compGuid)
Compare a GUID
Parameters:
Name | Type | Description | Default |
---|---|---|---|
compGuid
|
GUID
|
GUID to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
GUIDs are equal: True/False |
__hash__()
Create a hash from the GUID
Returns:
Type | Description |
---|---|
int
|
hash from the GUID |
__init__()
Initialize
__repr__()
Create a string from the GUID
Returns:
Type | Description |
---|---|
str
|
string from the GUID |