Functions of the module Utility
Module full path: NemAll_Python_Utility
Exposed utility classes and functions
CheckModuleLicence(moduleNumber)
Check for a module licence
Parameters:
Name | Type | Description | Default |
---|---|---|---|
moduleNumber
|
int
|
Number of the module |
required |
Returns:
Type | Description |
---|---|
bool
|
Licence for the module available: True/False |
ClearUnitTestDocument()
Clear the document
EncryptString(stringtoEncrypt, pypName)
ImportScript an encrypted PythonPart script
Parameters:
Name | Type | Description | Default |
---|---|---|---|
script
|
Path of the file |
required | |
pypName
|
str
|
Name of the PythonPart |
required |
ImportScript(script, global_dict, pypName)
ImportScript an encrypted PythonPart script
Parameters:
Name | Type | Description | Default |
---|---|---|---|
script
|
str
|
Path of the file |
required |
global_dict
|
object
|
File name |
required |
pypName
|
str
|
Name of the PythonPart |
required |
InitReinfNormInterpreter()
InitUnitTest(loadResources)
Initialize the unit test
Parameters:
Name | Type | Description | Default |
---|---|---|---|
loadResources
|
bool
|
Load the resources |
required |
IsExecutedByUnitTest()
Check, whether the script is executed by a unit test
Returns:
Type | Description |
---|---|
bool
|
Script is executed by a unit test: True/False |
LoadSymbolForUnitTest(file, clearDocument)
Load a symbol to the Array
Parameters:
Name | Type | Description | Default |
---|---|---|---|
file
|
str
|
File name |
required |
clearDocument
|
bool
|
Clear the document before symbol loading |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Created elements |
ShowMessageBox(text, flags)
Initialize the unit test
Parameters:
Name | Type | Description | Default |
---|---|---|---|
text
|
str
|
Message box text |
required |
flags
|
int
|
Button flags |
required |