PythonPartsSettings
Canonical path: NemAll_Python_AllplanSettings.PythonPartsSettings
Implementation of the PythonParts settings
Methods:
-
GetInstance
–Get the instance
-
SetLengthUnit
–Set the length unit
-
SetShowFullPreview
–Show the full preview
Attributes:
-
ShowFullPreview
(bool
) –Get the full preview state
-
UpdateIdenticalPythonParts
(UpdateIdenticalPythonPartsState
) –Get the update identical PythonParts state
ShowFullPreview
property
writable
Get the full preview state
Show the full preview
UpdateIdenticalPythonParts
property
writable
UpdateIdenticalPythonParts: UpdateIdenticalPythonPartsState
Get the update identical PythonParts state
GetInstance
staticmethod
GetInstance() -> PythonPartsSettings
SetLengthUnit
Set the length unit
Parameters:
-
lengthUnit
(int
) –Length unit: 3 = m
Placeholder