Skip to content

BeamProperties

Canonical path: NemAll_Python_ArchElements.BeamProperties

Bases: ArchBaseProperties

Representation of the properties of an upstand/downstand beam

Methods:

  • GetShapeType

    Get the type of the cross-section shape

  • GetWidth

    Get the width of the rectangular cross-section shape

  • SetAttribute

    Set the attribute

  • SetAxis

    Set the axis

  • SetShapeType

    Set the type of the cross-section shape

  • SetWidth

    Set the width of the rectangular cross-section shape

  • __init__

    Overloaded function. See individual overloads.

Attributes:

IsStartNewJoinedBeamGroup property writable

IsStartNewJoinedBeamGroup: bool

Should this beam be the first of a new group of beams joined together

Set this property to False in the second or subsequent beams in order to join all of them with each other at their ends to create a continous chain of beams.

ShapeType property writable

ShapeType: ShapeType

Type of the cross-section shape

Width property writable

Width: float

Width of the rectangular cross-section shape

GetShapeType

GetShapeType() -> ShapeType

Get the type of the cross-section shape

Returns:

GetWidth

GetWidth() -> float

Get the width of the rectangular cross-section shape

Returns:

  • float

    Width

SetAttribute

SetAttribute(attrib: object)

Set the attribute

Parameters:

  • attrib (object) –

    Attribute

SetAxis

SetAxis(axis: AxisProperties)

Set the axis

Parameters:

SetShapeType

SetShapeType(shapeType: ShapeType)

Set the type of the cross-section shape

Parameters:

SetWidth

SetWidth(width: float)

Set the width of the rectangular cross-section shape

Parameters:

  • width (float) –

    Width

__init__ overloaded

__init__()

Initialize

__init__(beamProp: BeamProperties)

Copy constructor

Parameters:

Placeholder