BottomTopPlaneService
Canonical path: NemAll_Python_ArchElements.BottomTopPlaneService
Service providing methods for reading various properties of the reference planes set in the current document.
GetAbsoluteBottomElevation
staticmethod
GetAbsoluteBottomElevation(
refElement: BaseElementAdapter,
doc: DocumentAdapter,
planeProp: BasePlaneReferences,
) -> float
Get the absolute elevation of the bottom plane
Parameters:
-
refElement
(BaseElementAdapter
) –Reference element (empty element if not exist)
-
doc
(DocumentAdapter
) –Document
-
planeProp
(BasePlaneReferences
) –Plane properties
Returns:
-
float
–Absolute elevation of the bottom plane
GetAbsoluteTopElevation
staticmethod
GetAbsoluteTopElevation(
refElement: BaseElementAdapter,
doc: DocumentAdapter,
planeProp: BasePlaneReferences,
) -> float
Get the absolute elevation of the top plane
Parameters:
-
refElement
(BaseElementAdapter
) –Reference element (empty element if not exist)
-
doc
(DocumentAdapter
) –Document
-
planeProp
(BasePlaneReferences
) –Plane properties
Returns:
-
float
–Absolute elevation of the top plane
GetBottomReferencePlane
staticmethod
GetBottomReferencePlane(
refElement: BaseElementAdapter,
doc: DocumentAdapter,
planeProp: BasePlaneReferences,
) -> BRep3D | Polyhedron3D | Plane3D
Get the bottom reference plane
Parameters:
-
refElement
(BaseElementAdapter
) –Reference element (empty element if not exist)
-
doc
(DocumentAdapter
) –Document
-
planeProp
(BasePlaneReferences
) –Plane properties
Returns:
-
BRep3D | Polyhedron3D | Plane3D
–Bottom reference plane as Plan3D, BRep3D or Polyhedron3D
GetDocumentBottomElevation
staticmethod
GetDocumentBottomElevation(
refElement: BaseElementAdapter,
doc: DocumentAdapter,
planeProp: BasePlaneReferences,
) -> float
Get the document elevation of the bottom plane
Parameters:
-
refElement
(BaseElementAdapter
) –Reference element (empty element if not exist)
-
doc
(DocumentAdapter
) –Document
-
planeProp
(BasePlaneReferences
) –Plane properties
Returns:
-
float
–Absolute elevation of the bottom plane
GetDocumentDefaultPlanes
staticmethod
GetDocumentDefaultPlanes(doc: DocumentAdapter) -> tuple[Plane3D, Plane3D]
Get the default bottom and top plane of the document
Parameters:
-
doc
(DocumentAdapter
) –Document
Returns:
GetDocumentTopElevation
staticmethod
GetDocumentTopElevation(
refElement: BaseElementAdapter,
doc: DocumentAdapter,
planeProp: BasePlaneReferences,
) -> float
Get the document elevation of the top plane
Parameters:
-
refElement
(BaseElementAdapter
) –Reference element (empty element if not exist)
-
doc
(DocumentAdapter
) –Document
-
planeProp
(BasePlaneReferences
) –Plane properties
Returns:
-
float
–Absolute elevation of the top plane
GetTopReferencePlane
staticmethod
GetTopReferencePlane(
refElement: BaseElementAdapter,
doc: DocumentAdapter,
planeProp: BasePlaneReferences,
) -> BRep3D | Polyhedron3D | Plane3D
Get the top reference plane
Parameters:
-
refElement
(BaseElementAdapter
) –Reference element (empty element if not exist)
-
doc
(DocumentAdapter
) –Document
-
planeProp
(BasePlaneReferences
) –Plane properties
Returns:
-
BRep3D | Polyhedron3D | Plane3D
–Bottom reference plane as Plan3D, BRep3D or Polyhedron3D