Skip to content

FlushPierElement

Canonical path: NemAll_Python_ArchElements.FlushPierElement

Bases: ArchElement, AllplanElement

Implementation of the FlushPier element

Methods:

Attributes:

Properties property writable

Properties: FlushPierProperties

Get the FlushPier properties

GetProperties

GetProperties() -> FlushPierProperties

Get the FlushPier properties

Returns:

SetProperties

SetProperties(FlushPierProp: FlushPierProperties)

Set the FlushPier properties

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(
    flushPierProp: FlushPierProperties,
    generalEle: BaseElementAdapter,
    startPnt: Point2D,
    endPnt: Point2D,
    drawPlacementPreview: bool,
)

Constructor

Parameters:

  • flushPierProp (FlushPierProperties) –

    FlushPier properties

  • generalEle (BaseElementAdapter) –

    General element which includes the FlushPier

  • startPnt (Point2D) –

    Start point of the FlushPier

  • endPnt (Point2D) –

    End point of the FlushPier

  • drawPlacementPreview (bool) –

    Draw a placement preview (no general element adaption) state

__init__(element: FlushPierElement)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string