Skip to content

FlushPierProperties

Canonical path: NemAll_Python_ArchElements.FlushPierProperties

Bases: ArchBaseProperties

Implementation of the FlushPier properties

Methods:

  • GetWidth

    Get the width of the Flush Pier

  • SetWidth

    Set the width of the Flush Pier

  • __init__

    Overloaded function. See individual overloads.

Attributes:

  • Width (float) –

    Get the width of the Flush Pier

Width property writable

Width: float

Get the width of the Flush Pier

GetWidth

GetWidth() -> float

Get the width of the Flush Pier

Returns:

  • float

    Width of the Flush Pier

SetWidth

SetWidth(width: float)

Set the width of the Flush Pier

Parameters:

  • width (float) –

    Width of the Flush Pier

__init__ overloaded

__init__()

Initialize

__init__(flushPierProp: FlushPierProperties)

Copy constructor

Parameters: