Skip to content

GeneralOpeningElement

Canonical path: NemAll_Python_ArchElements.GeneralOpeningElement

Bases: ArchElement, AllplanElement

Representation of (polygonal) niche, recess, slit or opening.

Properties property writable

Opening properties

__init__ overloaded

__init__()

Initialize with default values

__init__(
    wallOpeningProp: GeneralOpeningProperties,
    generalEle: BaseElementAdapter,
    startPnt: Point2D,
    endPnt: Point2D,
    drawPlacementPreview: bool,
)

Construct a regular niche, recess, slit or opening by start and end point

Parameters:

  • wallOpeningProp (GeneralOpeningProperties) –

    Opening properties

  • generalEle (BaseElementAdapter) –

    General element which includes the opening

  • startPnt (Point2D) –

    Start point of the opening

  • endPnt (Point2D) –

    End point

  • drawPlacementPreview (bool) –

    Set to True to draw preview before the opening is placed in an architectural component (no general element adaption). Set to False after the opening is placed in an opening.

__init__(
    wallOpeningProp: GeneralOpeningProperties,
    generalEle: BaseElementAdapter,
    groundPlanePolygon: Polygon2D,
    drawPlacementPreview: bool,
)

Construct a polygonal niche, recess, slit or opening

Parameters:

  • wallOpeningProp (GeneralOpeningProperties) –

    Opening properties

  • generalEle (BaseElementAdapter) –

    General element which includes the opening

  • groundPlanePolygon (Polygon2D) –

    Ground plan polygon

  • drawPlacementPreview (bool) –

    Set to True to draw preview before the opening is placed in an architectural component (no general element adaption). Set to False after the opening is placed in an opening.

__init__(element: GeneralOpeningElement)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string

Placeholder