Skip to content

GeneralOpeningProperties

Canonical path: NemAll_Python_ArchElements.GeneralOpeningProperties

Properties of a regular or polygonal niche, recess, slit or opening

Independent2DInteraction property writable

Independent2DInteraction: bool

Set to True, when the opening is above/below the section plane and should therefor NOT interact with the hatching/filling of the parent architectural element in ground view. Defaults to False.

OpeningType property writable

OpeningType: OpeningType

Get the type of the opening

PlaneReferences property writable

PlaneReferences: PlaneReferences

Get the plane references

VisibleInViewSection3D property writable

VisibleInViewSection3D: bool

When set to False, the opening does NOT cut out the 3D model element of the parent architectural component (hence opening is invisible in UVSs). Relevant for recess only! Defaults to True.

GetGeometryProperties

GetGeometryProperties() -> VerticalOpeningGeometryProperties

Get a reference of the geometry properties

Returns:

GetOpeningSymbolsProperties

GetOpeningSymbolsProperties() -> OpeningSymbolsProperties

Get a reference of the opening symbols properties

Returns:

GetSillProperties

GetSillProperties() -> VerticalOpeningSillProperties

Get a reference of the sill properties

Returns:

__init__ overloaded

__init__(openingType: OpeningType)

Constructor

Parameters:

__init__(openingProp: GeneralOpeningProperties)

Copy constructor

Parameters:

Placeholder