JointElement
Canonical path: NemAll_Python_ArchElements.JointElement
Bases: ArchElement
, AllplanElement
Implementation of the General opening element
Methods:
-
GetProperties
–Get the General opening properties
-
SetProperties
–Set the GeneralOpening properties
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
Properties
(JointProperties
) –Get the General opening properties
GetProperties
GetProperties() -> JointProperties
SetProperties
SetProperties(JointProp: JointProperties)
Set the GeneralOpening properties
Parameters:
-
JointProp
(JointProperties
) –General opening properties
__init__
overloaded
Initialize
__init__(
jointProp: JointProperties,
generalEle: BaseElementAdapter,
startPnt: Point2D,
endPnt: Point2D,
drawPlacementPreview: bool,
)
Constructor
Parameters:
-
jointProp
(JointProperties
) –Opening properties
-
generalEle
(BaseElementAdapter
) –General element which includes the opening
-
startPnt
(Point2D
) –Start point of the opening
-
endPnt
(Point2D
) –End point
-
drawPlacementPreview
(bool
) –Draw a placement preview (no general element adaption) state
__init__(element: JointElement)
Placeholder