ProfileCatalogService
Canonical path: NemAll_Python_ArchElements.ProfileCatalogService
Service providing methods returning profiles as geometrical objects (Path2D, Polyline2D) based on path pointing to a symbol (.sym file) containing a closed profile.
GetDoubleProfileGap
staticmethod
Gets double profile gap
Parameters:
-
fullProfileName
(str
) –Profile name with path
Returns:
-
float
–Double profile gap
GetFullProfileBoundaryPaths
staticmethod
GetFullProfileBoundaryPaths(
fullProfileName: str,
overrideDefaultGap: bool = False,
overrideGap: float = 0.0,
) -> Path2DList
Get the boundary path of the full profile (e.g. in case of double profile).
Parameters:
-
fullProfileName
(str
) –Profile name with path
-
overrideDefaultGap
(bool
, default:False
) –Override default gap for double profiles
-
overrideGap
(float
, default:0.0
) –Override gap for double profiles
Returns:
-
Path2DList
–Profile boundary paths
GetFullProfileBoundaryPolylines
staticmethod
GetFullProfileBoundaryPolylines(
fullProfileName: str,
overrideDefaultGap: bool = False,
overrideGap: float = 0.0,
) -> Polyline2DList
Get the boundary polylines of the full profile (e.g. in case of double profile).
Parameters:
-
fullProfileName
(str
) –Profile name with path
-
overrideDefaultGap
(bool
, default:False
) –Override default gap for double profiles
-
overrideGap
(float
, default:0.0
) –Override gap for double profiles
Returns:
-
Polyline2DList
–Profile boundary polylines
GetProfileAttributes
staticmethod
GetProfileAttributes(fullProfileName: str, doc: DocumentAdapter) -> list
Get the profile attributes
Parameters:
-
fullProfileName
(str
) –Profile name with path
-
doc
(DocumentAdapter
) –Document
Returns:
-
list
–Attributes
GetProfileBoundaryPath
staticmethod
GetProfileBoundaryPath(
fullProfileName: str,
overrideDefaultGap: bool = False,
overrideGap: float = 0.0,
) -> Path2D
Get the boundary path of the single profile
Parameters:
-
fullProfileName
(str
) –Profile name with path
-
overrideDefaultGap
(bool
, default:False
) –Override default gap for double profiles
-
overrideGap
(float
, default:0.0
) –Override gap for double profiles
Returns:
-
Path2D
–Profile boundary path
GetProfileBoundaryPolyline
staticmethod
GetProfileBoundaryPolyline(
fullProfileName: str,
overrideDefaultGap: bool = False,
overrideGap: float = 0.0,
) -> Polyline2D
Get the boundary polyline of the single profile
Parameters:
-
fullProfileName
(str
) –Profile name with path
-
overrideDefaultGap
(bool
, default:False
) –Override default gap for double profiles
-
overrideGap
(float
, default:0.0
) –Override gap for double profiles
Returns:
-
Polyline2D
–Profile boundary polyline
GetProfileGeometry
staticmethod
GetProfileGeometry(
fullProfileName: str,
overrideDefaultGap: bool = False,
overrideGap: float = 0.0,
) -> BRep3D
Get the profile geometry
Parameters:
-
fullProfileName
(str
) –Profile name with path
-
overrideDefaultGap
(bool
, default:False
) –Override default gap for double profiles
-
overrideGap
(float
, default:0.0
) –Override gap for double profiles
Returns:
-
BRep3D
–Profile geometry as BRep3D
GetProfilePlacementPoint
staticmethod
GetProfilePlacementPoint(
fullProfileName: str,
overrideDefaultGap: bool = False,
overrideGap: float = 0.0,
) -> Point3D
Get the profile placement point
Parameters:
-
fullProfileName
(str
) –Profile name with path
-
overrideDefaultGap
(bool
, default:False
) –Override default gap for double profiles
-
overrideGap
(float
, default:0.0
) –Override gap for double profiles
Returns:
-
Point3D
–Profile placement point as Point3D