PropertyDialogs
Canonical path: NemAll_Python_ArchElements.PropertyDialogs
Utility class providing methods related to architectural properties such as plane references or trade.
GetLastSymbolPath
staticmethod
Get the last symbol path
Returns:
-
str
–Last symbol path
GetSymbolName
staticmethod
Get the symbol name
Parameters:
-
symbolPath
(str
) –Symbol path
Returns:
-
str
–Symbol name
GetTradeDescription
staticmethod
Get the trade description
Parameters:
-
tradeID
(int
) –Trade ID
Returns:
-
str
–Trade description
OpenBottomPlaneReferenceDialog
staticmethod
OpenBottomPlaneReferenceDialog(
refElement: BaseElementAdapter,
doc: DocumentAdapter,
planeRefs: PlaneReferences,
) -> float
Open the plane references dialog
Returns:
-
float
–bottom height
Parameters:
-
refElement
(BaseElementAdapter
) –Reference element (empty element if not exist)
-
doc
(DocumentAdapter
) –Document
-
planeRefs
(PlaneReferences
) –Plane references
OpenPlaneReferencesDialog
staticmethod
OpenPlaneReferencesDialog(
refElement: BaseElementAdapter,
doc: DocumentAdapter,
planeRefs: PlaneReferences,
)
Open the plane references dialog
Parameters:
-
refElement
(BaseElementAdapter
) –Reference element (empty element if not exist)
-
doc
(DocumentAdapter
) –Document
-
planeRefs
(PlaneReferences
) –Plane references
OpenSmartSymbolPartDialog
staticmethod
OpenSmartSymbolPartDialog(
smartSymbolPath: str, showSmartSymbols: bool, showSmartParts: bool
) -> str
Open the library dialog for SmartSymbols and SmartParts
Returns:
-
str
–result path
Parameters:
-
smartSymbolPath
(str
) –Path to file
-
showSmartSymbols
(bool
) –Show smart symbols state
-
showSmartParts
(bool
) –Show SmartParts state
OpenSymbolDialog
staticmethod
Open the symbol library dialog
Returns:
-
str
–result path
Parameters:
-
symbolPath
(str
) –Path to .sym file
OpenTopPlaneReferenceDialog
staticmethod
OpenTopPlaneReferenceDialog(
refElement: BaseElementAdapter,
doc: DocumentAdapter,
planeRefs: PlaneReferences,
) -> float
Open the plane references dialog
Returns:
-
float
–top height
Parameters:
-
refElement
(BaseElementAdapter
) –Reference element (empty element if not exist)
-
doc
(DocumentAdapter
) –Document
-
planeRefs
(PlaneReferences
) –Plane references
OpenTradeDialog
staticmethod
OpenTradeDialog(doc: DocumentAdapter, tradeID: int) -> int
Open the trade dialog
Parameters:
-
doc
(DocumentAdapter
) –Document
-
tradeID
(int
) –Current trade ID
Returns:
-
int
–Trade ID