ShapeType
Canonical path: NemAll_Python_ArchElements.ShapeType
Bases: Enum
Types of cross sections of linear architectural objects, like beams or columns.
Attributes:
-
eArbitrary
– -
eCircular
–Round cross section
-
eConical
– -
ePolygonal
–Cross section bounded with a free, closed polygon
-
eProfile
–Cross section defined with a symbol from the library containing a closed profile
-
eRectangular
–Rectangular cross section
-
eRegularPolygonCircumscribed
–Cross section in a shape of a regular polygon circumscribed on a circle
-
eRegularPolygonInscribed
–Cross section in a shape of a regular polygon inscribed in a circle
-
eRiseBottomTop
– -
eUnknown
–
ePolygonal
class-attribute
instance-attribute
Cross section bounded with a free, closed polygon
eProfile
class-attribute
instance-attribute
Cross section defined with a symbol from the library containing a closed profile
eRegularPolygonCircumscribed
class-attribute
instance-attribute
Cross section in a shape of a regular polygon circumscribed on a circle
eRegularPolygonInscribed
class-attribute
instance-attribute
Cross section in a shape of a regular polygon inscribed in a circle