SlabElement
Canonical path: NemAll_Python_ArchElements.SlabElement
Bases: ArchElement
, AllplanElement
Implementation of the Slab element
Methods:
-
GetProperties
–Get the Slab properties
-
SetProperties
–Set the Slab properties
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
Properties
(SlabProperties
) –Get the Slab properties
GetProperties
GetProperties() -> SlabProperties
SetProperties
SetProperties(SlabProp: SlabProperties)
__init__
overloaded
Initialize
__init__(slabProp: SlabProperties, slabPolygon: Polygon2D)
Constructor
Parameters:
-
slabProp
(SlabProperties
) –Slab properties
-
slabPolygon
(Polygon2D
) –Slab polygon
__init__(element: SlabElement)
Placeholder