SlabOpeningProperties
Canonical path: NemAll_Python_ArchElements.SlabOpeningProperties
Bases: VerticalElementProperties
, ArchBaseProperties
Implementation of the slab opening properties
Methods:
-
GetOpeningSymbolsProperties
–Get a reference of the opening symbols properties
-
GetOpeningType
–Get the opening type
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
Independent2DInteraction
(bool
) –Get the independent 2D interaction state
Independent2DInteraction
property
writable
Get the independent 2D interaction state
GetOpeningSymbolsProperties
GetOpeningSymbolsProperties() -> OpeningSymbolsProperties
Get a reference of the opening symbols properties
Returns:
-
OpeningSymbolsProperties
–Opening symbols properties reference
GetOpeningType
GetOpeningType() -> SlabOpeningType
__init__
overloaded
__init__(openingType: SlabOpeningType = eOpening)
Constructor
__init__(openingProps: SlabOpeningProperties)
Placeholder