StructuralBeamElement
Canonical path: NemAll_Python_ArchElements.StructuralBeamElement
Bases: ArchElement
, AllplanElement
Representation of the structural framing beam
Methods:
-
GetStructuralBeamProperties
–Get the Structural Beam properties
-
SetAxisVisibility
–Set the Visibility of element axis
-
SetStructuralBeamProperties
–Set the Structural Beam properties
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
StructuralBeamProperties
(StructuralBeamProperties
) –Get the Structural Beam properties
StructuralBeamProperties
property
writable
StructuralBeamProperties: StructuralBeamProperties
Get the Structural Beam properties
GetStructuralBeamProperties
GetStructuralBeamProperties() -> StructuralBeamProperties
SetAxisVisibility
Set the Visibility of element axis
Parameters:
-
visibility
(bool
) –Bool if axis of element should be visible
SetStructuralBeamProperties
SetStructuralBeamProperties(properties: StructuralBeamProperties)
Set the Structural Beam properties
Parameters:
-
properties
(StructuralBeamProperties
) –Beam properties
__init__
overloaded
Placeholder