StructuralBraceElement
Canonical path: NemAll_Python_ArchElements.StructuralBraceElement
Bases: ArchElement
, AllplanElement
Representation of the structural framing bracing
Methods:
-
GetStructuralBraceProperties
–Get the Structural Brace properties
-
SetAxisVisibility
–Set the Visibility of element axis
-
SetStructuralBraceProperties
–Set the Structural Brace properties
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
StructuralBraceProperties
(StructuralBraceProperties
) –Get the Structural Brace properties
StructuralBraceProperties
property
writable
StructuralBraceProperties: StructuralBraceProperties
Get the Structural Brace properties
GetStructuralBraceProperties
GetStructuralBraceProperties() -> StructuralBraceProperties
SetAxisVisibility
Set the Visibility of element axis
Parameters:
-
visibility
(bool
) –Bool if axis of element should be visible
SetStructuralBraceProperties
SetStructuralBraceProperties(properties: StructuralBraceProperties)
Set the Structural Brace properties
Parameters:
-
properties
(StructuralBraceProperties
) –Brace properties
__init__
overloaded
Initialize
__init__(properties: StructuralBraceProperties)
__init__(element: StructuralBraceElement)
Placeholder