WallAxisPosition
Canonical path: NemAll_Python_ArchElements.WallAxisPosition
Bases: Enum
Position of the axis relative to the architectural component (any linear component, not only wall as the name might suggest).
Following descriptions assume that:
- the axis origins in (0,0)
- it points in +X direction
- Extension property is set to -1
Attributes:
-
eCenter
–Axis is in the center of the architectural component. Set the Distance property to the half of the component width!
-
eFree
–Position is defined by in the Distance property
-
eLeft
–Axis is on the left side of the component (on the +Y side). Set the Distance property to 0!
-
eRight
–Axis is on the right side of the component (on the -Y side). Set the Distance property to the width of the component!
-
eUnknown
–
eCenter
class-attribute
instance-attribute
Axis is in the center of the architectural component. Set the Distance property to the half of the component width!
eLeft
class-attribute
instance-attribute
Axis is on the left side of the component (on the +Y side). Set the Distance property to 0!
eRight
class-attribute
instance-attribute
Axis is on the right side of the component (on the -Y side). Set the Distance property to the width of the component!