WindowOpeningProperties
Canonical path: NemAll_Python_ArchElements.WindowOpeningProperties
Properties of window opening
Independent2DInteraction
property
writable
Set to True, when the opening is above/below the section plane and should therefor NOT interact with the hatching/filling of the parent architectural element in ground view. Defaults to False.
GetGeometryProperties
GetGeometryProperties() -> VerticalOpeningGeometryProperties
Get a reference of the geometry properties
Returns:
-
VerticalOpeningGeometryProperties
–Geometry properties reference
GetOpeningSymbolsProperties
GetOpeningSymbolsProperties() -> OpeningSymbolsProperties
Get a reference of the opening symbols properties
Returns:
-
OpeningSymbolsProperties
–Opening symbols properties reference
GetRevealProperties
GetRevealProperties() -> VerticalOpeningRevealProperties
Get a reference of the reveal properties
Returns:
-
VerticalOpeningRevealProperties
–Reveal properties reference
GetSillProperties
GetSillProperties() -> VerticalOpeningSillProperties
Get a reference of the sill properties
Returns:
-
VerticalOpeningSillProperties
–Sill properties reference
GetTierOffsetProperties
GetTierOffsetProperties() -> VerticalOpeningTierOffsetProperties
Get a reference of the tier offset properties
Returns:
-
VerticalOpeningTierOffsetProperties
–Tier offset properties reference
Placeholder