DocumentResourceService
Canonical path: NemAll_Python_BaseElements.DocumentResourceService
CreateSurface
staticmethod
CreateSurface(
doc: DocumentAdapter,
surfaceDirectoryPath: str,
localPathAndName: str,
surfaceDef: SurfaceDefinition,
createUniqueName: bool = True,
bitmapDefinitions: Dict[eSurfaceTextureID, BitmapDefinition] = {},
) -> str
Create a surface resource with a unique name
Parameters:
-
doc
(DocumentAdapter
) –Document
-
surfaceDirectoryPath
(str
) –Path to the surface directory (e.g. ...\std\design)
-
localPathAndName
(str
) –Local path and name (extends the surface directory path)
-
surfaceDef
(SurfaceDefinition
) –Surface definition
-
createUniqueName
(bool
, default:True
) –create a unique name state
-
bitmapDefinitions
(Dict[eSurfaceTextureID, BitmapDefinition]
, default:{}
) –Bitmap definitions
Returns:
-
str
–Unique name extension of the surface
Placeholder