DrawingService
Canonical path: NemAll_Python_BaseElements.DrawingService
Methods:
-
LockGraphicsEngineUpdate
–Lock the update of the graphics engine
-
RedrawAll
–Redraw all
-
ResetAndDrawHiddenElement
–Reset and draw the hidden elements
-
SaveWindowToImageFile
–Save the window to an image file
-
UpdateAllWindows
–Update the drawing in all windows
-
UpdateGraphicsEngine
–Update the graphics engine
LockGraphicsEngineUpdate
staticmethod
LockGraphicsEngineUpdate(doc: DocumentAdapter, lockUpdate: bool)
Lock the update of the graphics engine
Parameters:
-
doc
(DocumentAdapter
) –Document
-
lockUpdate
(bool
) –Set to True to lock the update of the graphics engine. Set to False to unlock and update it.
ResetAndDrawHiddenElement
staticmethod
ResetAndDrawHiddenElement(
doc: DocumentAdapter, hiddenElement: BaseElementAdapter
)
Reset and draw the hidden elements Args: doc Document hiddenElement Hidden element
SaveWindowToImageFile
staticmethod
Save the window to an image file
e:for success
UpdateGraphicsEngine
staticmethod
UpdateGraphicsEngine(doc: DocumentAdapter)
Update the graphics engine Args: doc Document
Placeholder